Already a client?  sign in


I lost my account details

no account yet?

see our pricing table and sign up!

Lost account

The fastest way to get your critical path planning information

FAQ

Which are the technical requirements for CPMST?
CPMST is designed not only for an ordinary PC or laptop but also for tablets like an iPad. CPMST is flexible and suitable for use with many modern platforms.
Minimum requirements for the effective use of CPMST include:
- The latest (or most recent) version of an Internet browser, eg. Internet Explorer version 9, Safari version 10.5, etc.
- Deactivation of the 'incognito' or 'private browsing' mode in the browser options.
- Java script must be running. This is usually the case. 

Is CPMST prepared for a tablet?
Yes, CPMST is ready for modern tablets such as an iPad.